Undefined variable: outp and customized template issue

Get help with installation and running YaBook guestbook here. Please do not post bug reports or feature requests here.

Moderators: Moderator Team, Development Team

Undefined variable: outp and customized template issue

Postby rioguia on Wed Dec 28, 2005 8:33 am

I really like your software and am grateful for it liberating my website from spammers. I have tried to follow all the suggestions in the forum that seemed to apply. I have the lastest php5 and mysql installed.

For the most part, YABook seems to work well. Users can add postings. As administrator, I can do all the normal features under "User Administration" and "Home." I am having a small trouble with the use of the administrative interface related to "Settings".

I am receiving the following errors when I attempt to access the administrative functions under "settings." The error messages follow:
Code: Select all
 [Notice: Undefined variable: outp in /Root/Directory/Apache/virtual_host/book/private/lib/common.inc.php on line 108

Warning: reset() [function.reset]: Passed variable is not an array or object in /Root/Directory/Apache/virtual_host/book/private/lib/sourdough/Sd_Html/Sd_Forms.class.php on line 261

Part of the problem may be related to my customized template. When I tried to customize the template (copying the original and simply modifying the header and footer file by echoing ' MY PHP AND HTML CODE HERE';), i got an error that the template could not be found. I checked my template name (dexter) and noted that the error message indicated that the script was looking for a template named "dexterdefault"

I renamed the custom template to dexterdefault and all worked until I attemped to access the "Settings" feature. When I did, the script reported it could not find the template "dexter." I copyied dexterdefault, creating a second template "dexter" and eliminated most of the error messages.

To eliminate the possibility that my template was the source of the error I changed the config-inc.php
define('YABO_TPL_PATH' , YABO_ROOT_PATH.'templates/dexter);
define('YABO_TPL_PATH' , YABO_ROOT_PATH.'templates/default');

Using the default template, I got this error message:
Code: Select all
Sd-Error: Could not load templates from ./templates/default/default//global.tpl.html. in //Root/Directory/Apache/virtual_host/book/private/lib/sourdough/thirdparty/patTemplate/patTemplate/Reader/File.php [patTemplate_Reader_File::_getFileContents] on line 127

I attempted to turn on debugging mode but that only resulted in an empty file in:

I searched Google and the forums and found only this related thread (search term "outp") but could not apply it to my issues. See:
http://forum.phpee.com/viewtopic.php?t= ... light=outp

Thanks in advance for any help you may offer.
Posts: 3
Joined: Wed Dec 28, 2005 8:02 am

Fixing configuration errors correct all problems

Postby rioguia on Wed Jan 04, 2006 4:59 am

this is a wonderful application and works excellently when installed correctly. My problems were caused by a configuration error caused by two incorrect settings:
define('YABO_TPL_PATH' , YABO_ROOT_PATH.'templates/dexter);

Template selections are made after logging in as Administrator and selecting
Settings/Design and specifying the custom template in the drop down menu.

The path error was caused by changing the YABook's directory name and failing to specify the change. This path is specified after logging in as Administrator and selecting:
Settings/General Settings/server url

I was not able to resolve the correct manner of starting the debugging log. Could someone point me to an answer or a resource explaining the logging system?
Posts: 3
Joined: Wed Dec 28, 2005 8:02 am

Return to YaBook Support

Who is online

Users browsing this forum: No registered users and 1 guest