login form

Report bugs of current version 2.2.5 here!

Moderators: Moderator Team, Development Team

login form

Postby dujl on Thu Jan 06, 2005 5:49 pm

Problably this isn't considered a real bug, but I find it annoying and incorrect.
When using preferably the keyboard (i try to avoid mouse as much as possible) and logging in using ID(tab)pwd-ENTER or even ID(tab)pwd(tab)ENTER it always results in incorect ID or pwd. I think this results from incorrect char filtering on unix.
Thank you, you have done a very ggod job.
Best wishes
Mike
dujl
 
Posts: 6
Joined: Thu Jan 06, 2005 5:18 pm
Location: Italia

Postby sdjl on Thu Jan 06, 2005 7:53 pm

It could be that when you press enter you technically haven't clicked the submit button.
Therefore, if the script making the login looks for the clicked button it results in nothing ending up in a failed login.

All you need to do is add a hidden field to the form and then check for that value when doing a login.

David
User avatar
sdjl
Moderator
 
Posts: 1282
Joined: Mon Nov 17, 2003 1:13 am
Location: London, UK

Postby dujl on Fri Jan 07, 2005 12:51 am

yes, that's what happens. But why doesn't it happen on most forms I use (and also those I made) ? I normally change field using the TAB (or sh/TAB) key, and submit with ENTER after the last field has been filled.
And it normally works. This also applies to standard auhentication form from Apache or Window based computers.
Thanks, Mike
dujl
 
Posts: 6
Joined: Thu Jan 06, 2005 5:18 pm
Location: Italia

Postby sdjl on Fri Jan 07, 2005 2:06 pm

Who knows hey :)
User avatar
sdjl
Moderator
 
Posts: 1282
Joined: Mon Nov 17, 2003 1:13 am
Location: London, UK


Return to PPhlogger bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron