Promblem with swedish letter å,ä, ö in keyword

Report bugs of current version 2.2.5 here!

Moderators: Moderator Team, Development Team

Promblem with swedish letter å,ä, ö in keyword

Postby PSN on Sun Dec 11, 2005 8:41 pm

For some reason the keywords is saved in the database with wrong character for the swedish letters å,ä,ö. I assume this is a bug and has anyone a solution for this?
User avatar
PSN
 
Posts: 113
Joined: Wed Mar 24, 2004 11:42 am
Location: Sweden

Postby sdjl on Sun Dec 11, 2005 9:35 pm

These aren't stored in the database. They are the language files which come with pphlogger and as far as i'm aware, they're correct in there.
It's a localisation problem with your GD library if anything, nothing else.

David
User avatar
sdjl
Moderator
 
Posts: 1282
Joined: Mon Nov 17, 2003 1:13 am
Location: London, UK

Postby PSN on Sun Dec 11, 2005 9:58 pm

Hi David,

I think you missunderstand me. I mean the keyword that is stored as "kw" in the url column in table pphl_XXXXX_mpdl.

So this has not anything to do with my other problem (creating image with text) even if its similar.
User avatar
PSN
 
Posts: 113
Joined: Wed Mar 24, 2004 11:42 am
Location: Sweden

Postby sdjl on Mon Dec 12, 2005 3:29 am

That again would be a localisation issue with PHP and/or MySQL.

David
User avatar
sdjl
Moderator
 
Posts: 1282
Joined: Mon Nov 17, 2003 1:13 am
Location: London, UK

Postby PSN on Mon Dec 12, 2005 4:14 am

Here is one solution for replace odd characters:

Code: Select all
$search = array('Ã¥''ã¥''Ã…''ã¤''ä''Ä''ö''Ö');
    
$replace = array('å','å','å','ä','ä','ä','ö','ö');
        foreach (
$replace as $char) {
   
$search[] = utf8_encode($char);


The above code did I place in dspStat on each output (3) for kw.
User avatar
PSN
 
Posts: 113
Joined: Wed Mar 24, 2004 11:42 am
Location: Sweden

Re: Promblem with swedish letter å,ä, ö in keyword

Postby Razr on Tue Apr 29, 2008 4:38 pm

Hi folks,

I'm having the same problems and would like to implement the above code.

But where exactly in dspSstats.php would it go?!?

I'm a little clueless here...

Thanks for any input ;)

Cheers,

Razr
Razr
 
Posts: 2
Joined: Tue Apr 29, 2008 4:34 pm


Return to PPhlogger bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron