PHPee.com PHP development forum
Statistics not working

 
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger Support
View previous topic :: View next topic  
Author Message
mihal



Joined: 10 Aug 2004
Posts: 3

PostPosted: Tue Aug 10, 2004 2:31 pm    Post subject: Statistics not working Reply with quote
Hi,
I have just installed the pphlogger and have a problem. If i use the php code instead of js it works. but if i use the js code (pphlogger.js) it doesn not work.

here is pphlogger.js - http://www.mountainbike.cz/pphlogger.js

and here is a code i put into the pages






Could someone help?
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 820
Location: London, UK

PostPosted: Tue Aug 10, 2004 4:05 pm    Post subject: Reply with quote
Code:

if (st=='js') { // calling PowerPhlogger by JavaScript-tag
   if (v != "Microsoft Internet Explorer") {
      r = r+"&url="+document.URL; // $HTTP_REFERER problem with NS,...
   }
   document.open();
   document.write("");
   document.close();
} else { // calling PowerPhlogger by IMG-tag
   rand = Math.round(1000*Math.random());
   r = r+"&b="+rand;  //force the page to load the IMG
   document.open();
   document.write("\"\"");
   document.close();
}


Look at the URL's. They are missing the .cz part to them. Change that and it should function.

You might want to look at the way you setup the script as this is most likely something to do with the URL you entered.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
mihal



Joined: 10 Aug 2004
Posts: 3

PostPosted: Tue Aug 10, 2004 4:18 pm    Post subject: Reply with quote
Thanks, now it works.. It seems that when you add new user the username is used to generate the script. and because a user was mountainbike, not mountainbike.cz there was missing the .cz

Michal
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 820
Location: London, UK

PostPosted: Tue Aug 10, 2004 7:54 pm    Post subject: Reply with quote
No, that's not the case.
The URL placed inside the pphlogger.js file is that which you setup when you installed the script.

THe username is also inserted into pphlogger.js, but at the very top as id:
Code:

id = "mountainbike.cz";


The URLs that i pointed you too shouldn't take any of their data based on the username, this is all correlated to the server the software is installed on.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
mihal



Joined: 10 Aug 2004
Posts: 3

PostPosted: Wed Aug 11, 2004 10:10 am    Post subject: Reply with quote
Yes, you are right. It seems I did not correctly write the server PPhlogger is running on. Now it works well.
Thanks for advices.
Back to top
View user's profile Send private message
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger Support All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.8
Theme design based on Team 101 Designs, modified by Philip Iezzi