PHPee.com PHP development forum
URLs not working properly

 
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger Support
View previous topic :: View next topic  
Author Message
mjames



Joined: 16 Aug 2004
Posts: 4
Location: Vienna, VA

PostPosted: Mon Aug 16, 2004 3:30 am    Post subject: URLs not working properly Reply with quote
I just installed 2.2.5 (I was using 2.2.3 previously, and it worked well). I noticed on my stats page under downloads and the other sections, all of the URLs are like this:

http://www.sports-central.orgwww.fantasyasylum.com/

My website is sports-central.org, but why are the URLs like that?

Two more minor questions. Do I disable e-mail notication about uniques by putting in 0? And is it possible to create logins for other people on my staff? I tried in the admin page, but it didn't give the same stats reports. I want just a different login for the same stats/site.

Thank you.
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 791
Location: London, UK

PostPosted: Mon Aug 16, 2004 11:15 am    Post subject: Reply with quote
You can't disable the email notification that i'm aware of. Set the email notification limit to something really high and that should do.

To provide other people logins to same statistics, you need to setup the guest account. Login to your account and navigate to the Profile section. On the left hand side towards the bottom there should be a check box that says "guest account". Check that and people can view your statistics by logging in with the username and password as guest.
Guest users will be unable to delete and change things, but it provides a way for them to view your stats.

Regarding your odd URL's, i don't know what could be causing that.
If you could provide me with a login to have a look for myself that may be of some use. You can PM me the details if you want details to remain confidential.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
mjames



Joined: 16 Aug 2004
Posts: 4
Location: Vienna, VA

PostPosted: Mon Aug 16, 2004 5:18 pm    Post subject: Reply with quote
I'm going to PM you my login info so you can take a look. Thanks...
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 791
Location: London, UK

PostPosted: Mon Aug 16, 2004 5:40 pm    Post subject: Reply with quote
I've just taken a look and i must say that is quite odd!
My first guess is that the script is only outputting URL's as www. without the http:// part. This causes browsers like IE to prepend the URL being displayed with the main URL of the website.

I can think of no other explanation as to why this might be happening, asides maybe from a misconfiguration somwhere in the main part of the script.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
mjames



Joined: 16 Aug 2004
Posts: 4
Location: Vienna, VA

PostPosted: Mon Aug 16, 2004 5:58 pm    Post subject: Reply with quote
Thanks. So is it something I did or is it the script? I wonder if the creator could give his input.

Another thing is the script is giving me this HTML code to use:
Code:





Where is it getting /stuff? The wierd thing is I have created that directory, but just to store images and stuff. I have no idea where it's getting that from or even knows about it.

Lastly, I set the e-mail notication to every uniques or whatever, and it changed to a different number, 2147483647. It isn't a problem, I'm just wondering why it changed to that number when I saved it? This script is doing word things for me.
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 791
Location: London, UK

PostPosted: Mon Aug 16, 2004 11:14 pm    Post subject: Reply with quote
go to setup.php under your admin directory. Check all URL's you entered in the setup and make sure they are correct.

The field type in MySQL for email notification is set to a certain limit. It changed the number to the greatest value that is allowed for that field type Smile

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
mjames



Joined: 16 Aug 2004
Posts: 4
Location: Vienna, VA

PostPosted: Mon Aug 16, 2004 11:37 pm    Post subject: Reply with quote
The only field that required me to enter a URL was the one in step 1 asking about the location of the root PPhlogger script. I fixed that, but I'm still getting the messed up URLs... It's interesting that only some of the links aren't formatted properly on the stats page. So work, some don't. I'm puzzled.
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 791
Location: London, UK

PostPosted: Tue Aug 17, 2004 12:06 pm    Post subject: Reply with quote
It could be that you need to remove all the pages that are listed already and let the script start again.
Maybe your best bet would be to remove the whole pphlogger account and then recreate it.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger Support All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.8
Theme design based on Team 101 Designs, modified by Philip Iezzi