PHPee.com PHP development forum
Calendar Problem (Unserialize ?!)

 
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger bug reports
View previous topic :: View next topic  
Author Message
alexandre



Joined: 29 Nov 2003
Posts: 11

PostPosted: Sat Dec 06, 2003 7:38 pm    Post subject: Calendar Problem (Unserialize ?!) Reply with quote
Ok.. Now that David resolved my login problem.. Here's another one.. Loll When I try to see the calendar.. Here's what i get: Notice: unserialize() [function.unserialize]: Error at offset 9 of 90 bytes in C:\wwwroot\pphlogger\modules\calendar.mod.php on line 96

I see that cause i configure my php.ini to show all errors and notice.. But i dont see anything else..

Does somebody have an idea what could be the problem? Again, my URL is: http://66.158.132.244/pphlogger/ you could use guest/guest as user/password

I changed the calendar page.. I just added: echo "$cache"; before: $cache_arr = unserialize($cache); just to know if there was really something in $cache and this is what i got: a:6:{i:0;s:1:\"0\";i:1;s:1:\"0\";i:2;s:1:\"0\";i:3;s:1:\"0\";i:4;s:1:\"0\";i:5;s:1:\"0\";}

Thanks again!
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Sun Dec 07, 2003 12:40 am    Post subject: Reply with quote
lol, another problem Very Happy
Do you have PHP set to the highest error reporting level?
Remember that the default error reporting level is not the highest that it can be thus meaning that Philip may not have coded PPHLogger with the highest error reporting turned on.

The login you provided doesn't work (guest/guest).

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
alexandre



Joined: 29 Nov 2003
Posts: 11

PostPosted: Sun Dec 07, 2003 12:58 am    Post subject: Reply with quote
Oups.. I forgot to create the user... now it's suppose to work.. hehe Very Happy Sorry for that! Lol
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Sun Dec 07, 2003 1:03 am    Post subject: Reply with quote
So have you set the error reporting level to high?
This account doesnt have any stats either.
It could be that the unserialize function is being used on no data causing an error.
Normally this error would be silent but because of the high error reporting level its pushed to the surface which is why you're getting errors.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
alexandre



Joined: 29 Nov 2003
Posts: 11

PostPosted: Sun Dec 07, 2003 4:36 am    Post subject: Reply with quote
No.. I tried it with an account having some stat..
Check.. I've put some stats in and there is the same error..

Here is how i configured the error in php.ini:
error_reporting = E_ALL

But even if I put it to:
error_reporting = E_ALL & ~E_NOTICE & ~E_WARNING
like it should be I get a blank screen

I don't know if this can help but check that.. I modified a little bit the calender.mod.php at line 95 for:

echo "$cache";
$cache_arr = unserialize($cache);
echo "$cache_arr";
if(!$cache_arr) exit;




echo "$cache"; return: a:6:{i:0;s:1:\"0\";i:1;s:1:\"0\";i:2;s:1:\"0\";i:3;s:1:\"0\";i:4;s:1:\"0\";i:5;s:1:\"0\";} like you see

and echo "$cache_arr"; return noting... so this is where the notice happend... and then it exit cause there nothing in it.. So its logical but why $cache_arr return nothing?? Here is the question!! I'm sure you will find the answer!!

Thanks Again!!
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Sun Dec 07, 2003 6:52 pm    Post subject: Reply with quote
I'm not too sure why it returns nothing to be honest. Quite a weird error.
Ill pass this one of to Philip and hope he has some suggestions Smile

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
alexandre



Joined: 29 Nov 2003
Posts: 11

PostPosted: Mon Dec 08, 2003 5:45 am    Post subject: Reply with quote
Ok I think Ive fixed my problem.. I think what resolved it was that I upgraded my PHP version to 4.3.4... but ive done alot of thing and maybe its another thing! loll Thanks again!
Back to top
View user's profile Send private message
alexandre



Joined: 29 Nov 2003
Posts: 11

PostPosted: Sat Dec 13, 2003 4:24 pm    Post subject: Reply with quote
OK... I've finnaly found what was the REAL problem.. it was in my php.ini... the line: magic_quotes_runtime has to be OFF if you want the calendar to work... So.. in php.ini:

magic_quotes_runtime = off

And it will work!!!
Back to top
View user's profile Send private message
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Sat Dec 13, 2003 7:08 pm    Post subject: Reply with quote
ah ha!
Well done on fixing the error.
Maybe some documentation about this would be good in future releases.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
Fusion



Joined: 15 Nov 2003
Posts: 71
Location: Hell, Norway

PostPosted: Mon Jan 12, 2004 5:53 am    Post subject: Reply with quote
sdjl wrote:
ah ha!
Well done on fixing the error.
Maybe some documentation about this would be good in future releases.

David

Indeed.. I'll have a look tonight to see if this fixes my blank pages aswell.

For the record though, I strongly urge this setting be specifically toggled in the code of the calendar. The fact that I as well as others have had this "error" occur indicates that it is no longer standard to leave the quotes off.
_________________
Toddler from Hell
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Fusion



Joined: 15 Nov 2003
Posts: 71
Location: Hell, Norway

PostPosted: Mon Jan 12, 2004 5:41 pm    Post subject: Reply with quote
Confirmed.

Add
Code:
set_magic_quote_runtime(0);

on the next line after
Code:

at the top of dspCalendar.php and you'll be all set regardless of what the php.ini dictates.

David,
Please tell Philip to add this to the package.
_________________
Toddler from Hell
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Mon Jan 12, 2004 6:23 pm    Post subject: Reply with quote
Fusion,

Philip reads these forums for himself, so the note about this should be added to the next version of PPHLogger Smile

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
Fusion



Joined: 15 Nov 2003
Posts: 71
Location: Hell, Norway

PostPosted: Mon Jan 12, 2004 6:32 pm    Post subject: Reply with quote
Heh, yea, but then he should've spotted this a long time ago. Wink
I made no less than 3 reports on this last year, and this is such a silly "bug" it needs to be stickied.
_________________
Toddler from Hell
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1013
Location: London, UK

PostPosted: Mon Jan 12, 2004 8:15 pm    Post subject: Reply with quote
*shrugs* such is life eh.

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
Post new topic   Reply to topic    phpee.com Forum Index -> PPhlogger bug reports All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB
Theme design based on Team 101 Designs, modified by Philip Iezzi