PHPee.com PHP development forum
HTTP_xxx_VARS is deprecated

 
Post new topic   Reply to topic    phpee.com Forum Index -> Phlogger3 feature requests
View previous topic :: View next topic  
Author Message
BHiker



Joined: 03 Jan 2004
Posts: 13
Location: Belgium

PostPosted: Sun Jan 04, 2004 11:24 am    Post subject: HTTP_xxx_VARS is deprecated Reply with quote
HTTP_xxx_VARS is deprecated and replaced by superglobals _xxx (http://be.php.net/manual/en/language.variables.predefined.php).

HTTP_xxx_VARS is used in login.php where HTTP_POST_VARS can safely be replaced by _POST.

// edit: found a few more:
In include\head.inc.php
Code:
" />
// should be:
" />

similar in libraries\defines.lib.php
and libraries\grab_globals.lib.php

BHiker
Back to top
View user's profile Send private message
V@no



Joined: 15 Nov 2003
Posts: 157

PostPosted: Sun Jan 04, 2004 5:34 pm    Post subject: Reply with quote
but for best compatibles the $HTTP_xxx_VARS should be "merged" with $_xxx
_________________
Back to top
View user's profile Send private message Visit poster's website
sdjl
Moderator


Joined: 17 Nov 2003
Posts: 1015
Location: London, UK

PostPosted: Sun Jan 04, 2004 7:51 pm    Post subject: Reply with quote
I think the reason $HTTP_XXX_VARS are used is because of people using lower versions of PHP where the newer version of super globals will not be recognised.

If you look at the Version 3 development page (https://phpee.com/pphlogger3-dev/) You will notice that the only versions of PHP that will be supported are 4.3.0 and greater.
I think we can safely say that the newer super globals will be used instead of the old style Smile

David
_________________
-----
Free Logger Accounts | PPHlogger Manual | PM Me
Back to top
View user's profile Send private message Visit poster's website
pipo
Site Admin


Joined: 15 Nov 2003
Posts: 761
Location: Zurich, Switzerland

PostPosted: Tue Feb 17, 2004 9:46 pm    Post subject: PPhlogger3 & PHP5 Reply with quote
Right, $HTTP_XXX_VARS are deprecated. PPhlogger 2.x actually should still run under PHP3 (AFAIK >= 3.0.9). There won't be any major changes in its code design as I took up development on PPhlogger3 again. As announced on https://phpee.com/pphlogger3-dev/, PPhlogger3 will only support PHP >= 4.3.0. Wrong, even here I have to correct myself: PPhlogger3 will ONLY support PHP 5! Currently PHP 5.0.0b4 is out and the final release is expected this summer. At this time I'm not going to explain why I made this decision. It's still not 100% sure, but there is a high chance that I'll drop all PHP4 support in this future version.
This is the first public announcement about this fact. I'm going to post about that in the announcement board as soon as I got more details.
_________________
Philip Iezzi - Development Team Leader, phpee.com
PHPee.com | Downloads | PPhlogger | CVS
Back to top
View user's profile Send private message Visit poster's website
Post new topic   Reply to topic    phpee.com Forum Index -> Phlogger3 feature requests All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB
Theme design based on Team 101 Designs, modified by Philip Iezzi